Hola q tal.

Tengo unos problemas con el módulo BS2,en concreto con 2 sensores y un motor que he puesto en dicho módulo, vereis... quiero q el servo gire cuando el sensor A (bumper) esté desactivado (0) y que cuando se active (1) se pare, pero no logro q lo haga, en principio, empieza a girar, pero cuando activo el sensor, no se para, si no q sigue girando, eso si, si dejo activado el bumper, y enciendo el BS2, entonces no gira el motor (algo estoy haciendo mal). Respecto al otro sensor (Bumper B), lo voy a utilizar, para q cuando se active el bumper A y se pare al motor, éste empieze a girar en sentido contrario, hasta q se active el bumper B y se pare de nuevo el motor.

A ver si me podeis dar alguna pista, porque no me sale y lo necesito hacer lo antes posible.
Un saludo desde España a todos los aficionados de la robótica.

Andrés

Visitas: 296

Responde a esto

Respuestas a esta discusión

Pues si,
publicaré alguna foto o video... ¿pero en q sección la pongo?.

Saludos
Puedes añadir fotos desde aquí:
http://www.aprenderobotica.com/photo/photo/newWithUploader
y agregarlas al album "Proyectos".
Gracias!



Andrés Lorite dijo:
Pues si,
publicaré alguna foto o video... ¿pero en q sección la pongo?.

Saludos
Hola Lorenzo,

He añadido unas fotos, y un pequeño video en el q se ve como abre y cierra la pinza. Cuando termine el programa, pondré un video más completa. Esta pinza también levanta el objeto una vez que esta se ha cerrado para poder transportar al mismo sin que se produzca roze en el suelo.

Un saludo.

Responder a debate

RSS

Cursos online y tutoriales


(se requiere registro previo gratuito en PortalArduino.com)

Mantenimiento del sitio



© 2018   Creado por Lorenzo M. Oliver.   [Imágenes licenciadas por Depositphotos.com] Tecnología de

Emblemas  |  Reportar un problema  |  Términos de servicio